.RU

Возведение в дробную степень - «Действиям»



^ Возведение в дробную степень


//В диалоговой форме - Лимит, Точность, СамоЧисло(неотрицательное) и //Степень.

//*******************************************

Функция ЦелаяСтепень(а,б)

Результат=1;

Для К=1 По б Цикл

Результат=Результат*а;

КонецЦикла;

Возврат Результат;

КонецФункции


Функция ЗнаковПослеТочки(Стр)

Перем К;

Номер=Найти(Стр,".");

Если Номер=0 Тогда

Возврат 0;

КонецЕсли;

НачалоНулей=Номер+1;

Для К=Номер+1 По СтрДлина(Стр) Цикл

Если Сред(Стр,К,1)"0" Тогда

НачалоНулей=К;

КонецЕсли;

КонецЦикла;

Возврат Макс(НачалоНулей-Номер,0);

КонецФункции


Функция Знак(Ч)

Если Ч=0 Тогда

Возврат 0;

ИначеЕсли Ч>0 Тогда

Возврат 1;

Иначе

Возврат -1;

КонецЕсли;

КонецФункции


Функция Корень10ВСтепени(Ч,Степень)

Перем а,б;

Если Степень<0 Тогда

Сообщить("Степень <0");

КонецЕсли;

_10ВСтепени=ЦелаяСтепень(10,Степень);

Если _10ВСтепени>1 Тогда

а=0;

б=Лимит;

РезА=Ч-ЦелаяСтепень(а,_10ВСтепени);

РезБ=Ч-ЦелаяСтепень(б,_10ВСтепени);

Пока 1=1 Цикл

Текущее=(а+б)/2;

Рез=Ч-ЦелаяСтепень(Текущее,_10ВСтепени);

Если Знак(Рез)*Знак(РезА)<0 Тогда

б=Текущее;

Иначе

а=Текущее;

КонецЕсли;

Если (а-б-Точность) Тогда

Возврат Текущее;

КонецЕсли;

КонецЦикла;

ИначеЕсли Степень=1 Тогда

Возврат Ч;

Иначе

Возврат 1;

КонецЕсли;

КонецФункции


Функция Степень_xyz(f,x,y,z)

Возврат ЦелаяСтепень(f,x)*ЦелаяСтепень(f,y)/Корень10ВСтепени(f,z);

КонецФункции


Функция ПоложительнаяДробнаяСтепень(а,ПоказательСтепени)

Перем Знак;

ЦелаяЧасть=Число(Строка(Цел(ПоказательСтепени)));

ДрЧасть=Сред(ПоказательСтепени,СтрДлина(Строка(ЦелаяЧасть))+2);

ВерхДробной=Число(СтрЗаменить(ДрЧасть,".",""));

Если ВерхДробной>0 Тогда

ДлинаДробной=ЗнаковПослеТочки(Строка(ПоказательСтепени));

Иначе

ДлинаДробной=0;

КонецЕсли;

x=ЦелаяСтепень(а,ЦелаяЧасть)*Корень10ВСтепени(ЦелаяСтепень(а,ВерхДробной),ДлинаДробной);

Возврат x;

КонецФункции


Функция Степень(а,б)

Если б<0 Тогда

НашаА=1/а;

НашаБ=-б;

Иначе

НашаА=а;

НашаБ=б;

КонецЕсли;

Сообщить(ПоложительнаяДробнаяСтепень(НашаА,НашаБ));

Возврат ПоложительнаяДробнаяСтепень(НашаА,НашаБ);

КонецФункции

Лимит=9999999;

Точность=0.001;




           

^ Вычисление мат.функций с помощью VBScript

Для вычисления мат.функций можно воспользоваться VBScript. Доступны следущие:

Abs - абсолютное значение
Atn - арктангенс
Cos - косинус
Exp - экспонента (число е в степени)
Fix - отбрасывает дробную часть числа
Int - целая часть числа (в 1с уже есть)
Log - натуральный логарифм (тоже есть)
Rnd - случайное число
Sgn - знак числа
Sin - синус
Sqr - квадратный корень
Tan - тангенс
Hex - перевод из 10-тичной в 16-ричную
Oct - в 8-ричную

Пример вызова:

// синус

function sin(value,sc=0)

try

if sc=0 then

sc=createObject("MSScriptControl.ScriptControl");

endif;

sc.language="VBscript";

except

return getEmptyValue();

endtry;

return sc.eval("sin("+value+")");

endFunction

Возведение в степень ( value1^value2) можно реализовать так:

sc.eval(""+value1+"^"+value2);


"Факториал" или "Пример рекурсии"


Функция Факториал(Значение)

Если Значение=0 Тогда Возврат 1 КонецЕсли;

Возврат Значение * Факториал(Значение-1);

КонецФункции


http://www.kb.mista.ru/article.php?id=79


v8: Выгонялка пользователей для 1С 7.7, 8.0, 8.1

Как принудительно отключить пользователей от базы




Автор статьи: Волшебник | Редакторы: Гений 1С, TormozIT, romix, nop
Последняя редакция №23 от 07.12.07 | ^ История
URL: http://kb.mista.ru/article.php?id=79





Ключевые слова: выгнать, из базы, отключить, пользователь, завершить, ЗавершитьРаботуСистемы, принудительно, отрубить


7.7

^ Администрирование 1С: работа с пользователями.
Как дистанционно кикнуть юзера ?
^ Народ и всё же я по поводу отваливания юзеров из базы на SQL автоматом
Существуют ли выгонялки, справляющиеся с модальными окнами?
^ Как выгнать пользователей?
Как средствами SQl отключить пользователей от данных
^ Как выбросить пользователей из 1С?
Отключить пользователя 1С с другого ПК
^ И всё же ещё раз как отключить пользователей 1с7.7 через командую строку
Как выкинуть всех из базы без спроса?
^ Как организовать принудительное отключение пользователей
Отключение пользователей
^ Как отключить пользователя
Дистанционное отключение раб. пользователей в 1С
принудительное отключение пользователей
^ Принудительное программное отключение пользователей для монопольного входа
Отключение пользователей
^ Книга знаний: Альтернативная выгонялка пользователей для 1С
(от romix) Я использую Книга знаний: Альтернативное стартовое окно для 1С:Предприятие 7.7

8.0

v8: Как выкинуть пользователя и базы?
v8: Всем выйти из Базы!
v8: ЗавершитьРаботуСистемы()
v8: Возможно ли средствами 1С выкинуть пользователей?
v8: отключить вручную пользователя из "Списка активных пользователей 1С"
v8: Программный разрыв соединений пользователей
v8: Есть ли в 8.0 механизм позволяющий отключить от базы данных пользователя?
v8: Как определить активных пользователей v 8.0
v8: Как отрубить пользователей и перезапустить сервер 8.1
^ Книга знаний: v8: Как выгнать пользователей из базы УПП


TSProcessKiller, утилита от Мулька:
Килл указанному процессу на указанных серваках.
http://kb.mista.ru/files/79/TSProcessKiller.rar

Другой способ убийства процессов - командная строка, например, команда
tskill notepad /A
убъет блокноты у всех юзеров на этом сервере.

'VBS. Cкрипт осуществляет отключение всех подключений к ИБ 1С:Предприятия v8.0.


'имя пользователя 1С:Предприятия

UserName = "TormozIT"


'пароль пользователя 1С:Предприятия

UserPass = "f43_!dPOD"


'имя сервера 1С

ServerName = "Tamo"

BaseName = "UPP12"


'Удаление всех соединений заданной ИБ сервера 1С

Dim connector

Set connector = CreateObject("v8.COMConnector")


Dim server

Set server = connector.ConnectServer(ServerName)

server.AddAuthentication UserName, UserPass

Dim ibDesc

Set ibDesc = server.CreateInfoBaseInfo()

ibDesc.Name = BaseName

Dim connections

connections = server.GetIBConnections(ibDesc)

Dim i

Dim connection

For i = LBound(connections) To UBound(connections)

set connection = connections(i)

server.Disconnect connection

Next


'VBS. Cкрипт осуществляет отключение всех подключений к ИБ 1С:Предприятия v8.1.

'На сервере подразумевается наличие только одного кластера и только одного рабочего процесса


'имя пользователя 1С:Предприятия

UserName = "TormozIT"


'пароль пользователя 1С:Предприятия

UserPass = "f43_!dPOD"


'имя сервера 1С

ServerName = "Tamo"

BaseName = "UPP12"


'Удаление всех соединений заданной ИБ сервера 1С


Dim Connector

Dim AgentConnection

Dim Cluster

Dim WorkingProcess

Dim WorkingProcessConnection

Dim ibDesc

Dim connections

Dim ConnectString


Set connector = CreateObject("V81.COMConnector")

Set AgentConnection = Connector.ConnectAgent(ServerName)

Set Cluster = AgentConnection.GetClusters()(0)

AgentConnection.Authenticate Cluster, "", ""

Set WorkingProcess = AgentConnection.GetWorkingProcesses(Cluster)(0)

ConnectString = WorkingProcess.HostName & ":" & WorkingProcess.MainPort

Set WorkingProcessConnection = Connector.ConnectWorkingProcess(ConnectString)

WorkingProcessConnection.AddAuthentication UserName, UserPass

Set ibDesc = WorkingProcessConnection.CreateInfoBaseInfo()

ibDesc.Name = BaseName

Connections = WorkingProcessConnection.GetInfoBaseConnections(ibDesc)


Dim i

Dim Connection

For i = LBound(Connections) To UBound(Connections)

set Connection = connections(i)

If (Connection.AppID "COMConsole") then

WorkingProcessConnection.Disconnect Connection

End if

Next

vs-chershincev-k-n-ponomarev-redakcionnaya-kollegiya.html
vs-ort1-uchebnoe-posobie-po-podgotovke.html
vs-visockij-1-chas-rabochaya-programma-po-literature-5-9-klassi.html
vsasivayushaya-turbina-shauberger-viktor-energiya-vodi.html
vse-bileti-imeyut-odnu-i-tu-zhe-strukturu-dva-teoreticheskih-voprosa-i-dve-zadachi-raznogo-urovnya-slozhnosti.html
vse-chelovechestvo-protiv-narkotikov-informacionnij-dajdzhest-agtu.html
  • textbook.bystrickaya.ru/kak-udvoit-vvp-pervij-shag-k-rossijskomu-ekonomicheskomu-chudu-a-illarionov.html
  • composition.bystrickaya.ru/pokazateli-investicii-i-ih-mesto-v-ekonomicheskoj-sisteme.html
  • otsenki.bystrickaya.ru/rossijskoj-federacii-postanovlenie-stranica-17.html
  • student.bystrickaya.ru/36-prava-i-obyazannosti-studentov-v-period-praktiki-temi-vipusknih-kvalifikacionnih-rabot-32-6-trebovaniya-k-tekstovomu.html
  • lecture.bystrickaya.ru/6-dinamika-osnovnih-tehniko-ekonomicheskih-pokazatelej-respubliki-bashkortostan.html
  • credit.bystrickaya.ru/otchet-po-pervoj-proizvodstvennoj-praktike-soderzhanie-stranica-4.html
  • klass.bystrickaya.ru/74-pansionat-sosnovij-bor-gostinichnij-kompleks-abramcevo-5-park-otel-atlas-6-pansionat-akvareli-7.html
  • apprentice.bystrickaya.ru/vnutrennij-kontrol-2.html
  • college.bystrickaya.ru/2tematika-kursovih-rabot-metodicheskie-ukazaniya-po-vipolneniyu-kursovoj-raboti-dlya-studentov-vshu-nispo-agrarnih.html
  • teacher.bystrickaya.ru/glava-35-anzhelika-s-sostradaniem-vzglyanula-na-podrostka-kotorogo-ohrannik-chyu-golovu-pokrivalo-nekoe-podobie.html
  • writing.bystrickaya.ru/4-podhodi-k-izucheniyu-otnosheniya-lichnost-kultura-rozin-v-m-r64-kulturologiya-uchebnik-2-e-izd-pererab-i-dop.html
  • turn.bystrickaya.ru/perspektivi-razvitiya-pedagogicheskih-tehnologij.html
  • upbringing.bystrickaya.ru/lekciya-5-6-chasov-seti-petri.html
  • lecture.bystrickaya.ru/andrej-nikolaev-oleg-markeev.html
  • paragraf.bystrickaya.ru/vvedenie-programma.html
  • knowledge.bystrickaya.ru/metodicheskie-ukazaniya-po-vipolneniyu-kontrolnoj-raboti-dlya-samostoyatelnoj-raboti-studentov-ii-kursa-obuchayushihsya-po-napravleniyam.html
  • report.bystrickaya.ru/istoriya-bumagi-bistrova-alisa.html
  • thesis.bystrickaya.ru/poryadok-predostavleniya-v-2012-godu-subsidij-na-provedenie-kapitalnogo-remonta.html
  • notebook.bystrickaya.ru/instrukciya-dlya-uchastnika-razmesheniya-zakaza-putem-zaprosa-kotirovok-prilozhenie-1-5-stranica-7.html
  • prepodavatel.bystrickaya.ru/strategicheskij-plan-ministerstva-industrii-i-novih-tehnologij-respubliki-kazahstan-na-2011-2015-godi-stranica-5.html
  • lesson.bystrickaya.ru/public-relations-chast-2.html
  • zanyatie.bystrickaya.ru/organizaciya-transportnogo-processa.html
  • prepodavatel.bystrickaya.ru/tema-uroka-osobennosti-kompozicii-rasskaza-iabunina-gospodin-iz-san-francisko.html
  • exam.bystrickaya.ru/v-sibiri-proizoshlo-zemletryasenie-informacionnoe-agentstvo-regnum-10022011-rossijskie-smi-o-mchs-monitoring-za-13-oktyabr-2011-g.html
  • bystrickaya.ru/viskazhite-pozhalujsta-svoyo-mnenie-ob-indijskom-tance-svami-satyananda-sarasvati-bhakti-joga-sagar.html
  • universitet.bystrickaya.ru/tema-vchem-istinnij-sterzhen-zhizni-cheloveka-mir-glazami-drevnerusskogo-cheloveka.html
  • essay.bystrickaya.ru/distancionnij-kraevoj-konkurs-etot-prekrasnij-udivitelnij-i-zagadochnij-mir.html
  • doklad.bystrickaya.ru/v-poiskah-bonusov-rasskazivaet-nachalnik-otdela-zagranichnih-pasportov-ufms-rossii-po-novosibirskoj-oblasti-elena.html
  • bukva.bystrickaya.ru/ochilov-dzhahongir-kamalovich-pravozashitnij-centr-memorial-.html
  • spur.bystrickaya.ru/kopilov-v-a-geografiya-naseleniya-uchebnoe-posobie-2-e-izd-pererab-i-dop.html
  • desk.bystrickaya.ru/perechen-dokumentov-oao-rzhd-mps-po-ohrane-truda-promishlennoj-pozharnoj-bezopasnosti-i-neproizvodstvennomu-travmatizmu-dejstvuyushih-v-oao-rzhd-moskva-mart-2009-g-stranica-10.html
  • otsenki.bystrickaya.ru/respubliki-tatarstan-o-vnesenii-izmenenij-v-byudzhetnij-kodeks-respubliki-tatarstan-stranica-2.html
  • zanyatie.bystrickaya.ru/sovet-federacii-federalnogo-sobraniya-rossijskoj-federacii-komiteti-i-komissii.html
  • knowledge.bystrickaya.ru/novij-glava-administracii-arhangelskoj-oblasti-ilya-mihalchuk-oficialno-vstupil-v-dolzhnost.html
  • ucheba.bystrickaya.ru/programma-disciplini-sociologiya-povsednevnosti-dlya-napravleniya-040200-68-sociologiya-dlya-podgotovki-magistra.html
  • © bystrickaya.ru
    Мобильный рефератник - для мобильных людей.