.RU

Возведение в дробную степень - «Действиям»



^ Возведение в дробную степень


//В диалоговой форме - Лимит, Точность, СамоЧисло(неотрицательное) и //Степень.

//*******************************************

Функция ЦелаяСтепень(а,б)

Результат=1;

Для К=1 По б Цикл

Результат=Результат*а;

КонецЦикла;

Возврат Результат;

КонецФункции


Функция ЗнаковПослеТочки(Стр)

Перем К;

Номер=Найти(Стр,".");

Если Номер=0 Тогда

Возврат 0;

КонецЕсли;

НачалоНулей=Номер+1;

Для К=Номер+1 По СтрДлина(Стр) Цикл

Если Сред(Стр,К,1)"0" Тогда

НачалоНулей=К;

КонецЕсли;

КонецЦикла;

Возврат Макс(НачалоНулей-Номер,0);

КонецФункции


Функция Знак(Ч)

Если Ч=0 Тогда

Возврат 0;

ИначеЕсли Ч>0 Тогда

Возврат 1;

Иначе

Возврат -1;

КонецЕсли;

КонецФункции


Функция Корень10ВСтепени(Ч,Степень)

Перем а,б;

Если Степень<0 Тогда

Сообщить("Степень <0");

КонецЕсли;

_10ВСтепени=ЦелаяСтепень(10,Степень);

Если _10ВСтепени>1 Тогда

а=0;

б=Лимит;

РезА=Ч-ЦелаяСтепень(а,_10ВСтепени);

РезБ=Ч-ЦелаяСтепень(б,_10ВСтепени);

Пока 1=1 Цикл

Текущее=(а+б)/2;

Рез=Ч-ЦелаяСтепень(Текущее,_10ВСтепени);

Если Знак(Рез)*Знак(РезА)<0 Тогда

б=Текущее;

Иначе

а=Текущее;

КонецЕсли;

Если (а-б-Точность) Тогда

Возврат Текущее;

КонецЕсли;

КонецЦикла;

ИначеЕсли Степень=1 Тогда

Возврат Ч;

Иначе

Возврат 1;

КонецЕсли;

КонецФункции


Функция Степень_xyz(f,x,y,z)

Возврат ЦелаяСтепень(f,x)*ЦелаяСтепень(f,y)/Корень10ВСтепени(f,z);

КонецФункции


Функция ПоложительнаяДробнаяСтепень(а,ПоказательСтепени)

Перем Знак;

ЦелаяЧасть=Число(Строка(Цел(ПоказательСтепени)));

ДрЧасть=Сред(ПоказательСтепени,СтрДлина(Строка(ЦелаяЧасть))+2);

ВерхДробной=Число(СтрЗаменить(ДрЧасть,".",""));

Если ВерхДробной>0 Тогда

ДлинаДробной=ЗнаковПослеТочки(Строка(ПоказательСтепени));

Иначе

ДлинаДробной=0;

КонецЕсли;

x=ЦелаяСтепень(а,ЦелаяЧасть)*Корень10ВСтепени(ЦелаяСтепень(а,ВерхДробной),ДлинаДробной);

Возврат x;

КонецФункции


Функция Степень(а,б)

Если б<0 Тогда

НашаА=1/а;

НашаБ=-б;

Иначе

НашаА=а;

НашаБ=б;

КонецЕсли;

Сообщить(ПоложительнаяДробнаяСтепень(НашаА,НашаБ));

Возврат ПоложительнаяДробнаяСтепень(НашаА,НашаБ);

КонецФункции

Лимит=9999999;

Точность=0.001;




           

^ Вычисление мат.функций с помощью VBScript

Для вычисления мат.функций можно воспользоваться VBScript. Доступны следущие:

Abs - абсолютное значение
Atn - арктангенс
Cos - косинус
Exp - экспонента (число е в степени)
Fix - отбрасывает дробную часть числа
Int - целая часть числа (в 1с уже есть)
Log - натуральный логарифм (тоже есть)
Rnd - случайное число
Sgn - знак числа
Sin - синус
Sqr - квадратный корень
Tan - тангенс
Hex - перевод из 10-тичной в 16-ричную
Oct - в 8-ричную

Пример вызова:

// синус

function sin(value,sc=0)

try

if sc=0 then

sc=createObject("MSScriptControl.ScriptControl");

endif;

sc.language="VBscript";

except

return getEmptyValue();

endtry;

return sc.eval("sin("+value+")");

endFunction

Возведение в степень ( value1^value2) можно реализовать так:

sc.eval(""+value1+"^"+value2);


"Факториал" или "Пример рекурсии"


Функция Факториал(Значение)

Если Значение=0 Тогда Возврат 1 КонецЕсли;

Возврат Значение * Факториал(Значение-1);

КонецФункции


http://www.kb.mista.ru/article.php?id=79


v8: Выгонялка пользователей для 1С 7.7, 8.0, 8.1

Как принудительно отключить пользователей от базы




Автор статьи: Волшебник | Редакторы: Гений 1С, TormozIT, romix, nop
Последняя редакция №23 от 07.12.07 | ^ История
URL: http://kb.mista.ru/article.php?id=79





Ключевые слова: выгнать, из базы, отключить, пользователь, завершить, ЗавершитьРаботуСистемы, принудительно, отрубить


7.7

^ Администрирование 1С: работа с пользователями.
Как дистанционно кикнуть юзера ?
^ Народ и всё же я по поводу отваливания юзеров из базы на SQL автоматом
Существуют ли выгонялки, справляющиеся с модальными окнами?
^ Как выгнать пользователей?
Как средствами SQl отключить пользователей от данных
^ Как выбросить пользователей из 1С?
Отключить пользователя 1С с другого ПК
^ И всё же ещё раз как отключить пользователей 1с7.7 через командую строку
Как выкинуть всех из базы без спроса?
^ Как организовать принудительное отключение пользователей
Отключение пользователей
^ Как отключить пользователя
Дистанционное отключение раб. пользователей в 1С
принудительное отключение пользователей
^ Принудительное программное отключение пользователей для монопольного входа
Отключение пользователей
^ Книга знаний: Альтернативная выгонялка пользователей для 1С
(от romix) Я использую Книга знаний: Альтернативное стартовое окно для 1С:Предприятие 7.7

8.0

v8: Как выкинуть пользователя и базы?
v8: Всем выйти из Базы!
v8: ЗавершитьРаботуСистемы()
v8: Возможно ли средствами 1С выкинуть пользователей?
v8: отключить вручную пользователя из "Списка активных пользователей 1С"
v8: Программный разрыв соединений пользователей
v8: Есть ли в 8.0 механизм позволяющий отключить от базы данных пользователя?
v8: Как определить активных пользователей v 8.0
v8: Как отрубить пользователей и перезапустить сервер 8.1
^ Книга знаний: v8: Как выгнать пользователей из базы УПП


TSProcessKiller, утилита от Мулька:
Килл указанному процессу на указанных серваках.
http://kb.mista.ru/files/79/TSProcessKiller.rar

Другой способ убийства процессов - командная строка, например, команда
tskill notepad /A
убъет блокноты у всех юзеров на этом сервере.

'VBS. Cкрипт осуществляет отключение всех подключений к ИБ 1С:Предприятия v8.0.


'имя пользователя 1С:Предприятия

UserName = "TormozIT"


'пароль пользователя 1С:Предприятия

UserPass = "f43_!dPOD"


'имя сервера 1С

ServerName = "Tamo"

BaseName = "UPP12"


'Удаление всех соединений заданной ИБ сервера 1С

Dim connector

Set connector = CreateObject("v8.COMConnector")


Dim server

Set server = connector.ConnectServer(ServerName)

server.AddAuthentication UserName, UserPass

Dim ibDesc

Set ibDesc = server.CreateInfoBaseInfo()

ibDesc.Name = BaseName

Dim connections

connections = server.GetIBConnections(ibDesc)

Dim i

Dim connection

For i = LBound(connections) To UBound(connections)

set connection = connections(i)

server.Disconnect connection

Next


'VBS. Cкрипт осуществляет отключение всех подключений к ИБ 1С:Предприятия v8.1.

'На сервере подразумевается наличие только одного кластера и только одного рабочего процесса


'имя пользователя 1С:Предприятия

UserName = "TormozIT"


'пароль пользователя 1С:Предприятия

UserPass = "f43_!dPOD"


'имя сервера 1С

ServerName = "Tamo"

BaseName = "UPP12"


'Удаление всех соединений заданной ИБ сервера 1С


Dim Connector

Dim AgentConnection

Dim Cluster

Dim WorkingProcess

Dim WorkingProcessConnection

Dim ibDesc

Dim connections

Dim ConnectString


Set connector = CreateObject("V81.COMConnector")

Set AgentConnection = Connector.ConnectAgent(ServerName)

Set Cluster = AgentConnection.GetClusters()(0)

AgentConnection.Authenticate Cluster, "", ""

Set WorkingProcess = AgentConnection.GetWorkingProcesses(Cluster)(0)

ConnectString = WorkingProcess.HostName & ":" & WorkingProcess.MainPort

Set WorkingProcessConnection = Connector.ConnectWorkingProcess(ConnectString)

WorkingProcessConnection.AddAuthentication UserName, UserPass

Set ibDesc = WorkingProcessConnection.CreateInfoBaseInfo()

ibDesc.Name = BaseName

Connections = WorkingProcessConnection.GetInfoBaseConnections(ibDesc)


Dim i

Dim Connection

For i = LBound(Connections) To UBound(Connections)

set Connection = connections(i)

If (Connection.AppID "COMConsole") then

WorkingProcessConnection.Disconnect Connection

End if

Next

vs-chershincev-k-n-ponomarev-redakcionnaya-kollegiya.html
vs-ort1-uchebnoe-posobie-po-podgotovke.html
vs-visockij-1-chas-rabochaya-programma-po-literature-5-9-klassi.html
vsasivayushaya-turbina-shauberger-viktor-energiya-vodi.html
vse-bileti-imeyut-odnu-i-tu-zhe-strukturu-dva-teoreticheskih-voprosa-i-dve-zadachi-raznogo-urovnya-slozhnosti.html
vse-chelovechestvo-protiv-narkotikov-informacionnij-dajdzhest-agtu.html
  • write.bystrickaya.ru/glava-7-pervaya-propoved-edvard-tomas.html
  • learn.bystrickaya.ru/glava-iii-nemeckaya-klassicheskaya-filosofiya-sothodom-ot-religii-novoe-estestvennonauchnoe-mishlenie-yavno-ne-imelo-nichego-obshego.html
  • klass.bystrickaya.ru/andrej-kruz.html
  • books.bystrickaya.ru/dopolnitelnaya-uchebnaya-literatura-uchebno-metodicheskij-kompleks-disciplini-en-f-01-koncepcii-sovremennogo-estestvoznaniya.html
  • abstract.bystrickaya.ru/263-orgtehnika-proekcionnaya-tehnika-svedeniya-o-rezultatah-samoobsledovaniya.html
  • reading.bystrickaya.ru/kratkaya-russkaya-pravda-xi-vek.html
  • control.bystrickaya.ru/e-s-evdokimova-kandidat-pedagogicheskih-nauk-docent.html
  • thesis.bystrickaya.ru/programma-disciplini-klinicheskaya-i-specialnaya-psihologiya-dlya-napravleniya-521000-psihologiya-podgotovki-bakalavra.html
  • college.bystrickaya.ru/22--privodit-primeri-rabochaya-programma-dlya-9-klassa-poyasnitelnaya-zapiska-kalendarno-tematicheskoe.html
  • letter.bystrickaya.ru/mifi-drevnej-grecii-videomaterialov.html
  • uchebnik.bystrickaya.ru/vasilij-fedorovich-denisov-prototip-gusarskogo-rotmistra-v-etom-zvanii-on-vpervie-upominaetsya-na-stranicah-tolstogo-denisova-gusarskij-oficer-geroj-vojni-1.html
  • znanie.bystrickaya.ru/administrativnij-reglament-po-organizacii-priema-zayavok-na-poleznuyu-model-stranica-4.html
  • reading.bystrickaya.ru/komitet-po-obrazovaniyu-p-r-i-k-a-z-doklad-municipalnogo-obsheobrazovatelnogo-uchrezhdeniya-licej-prikladnih-nauk.html
  • uchit.bystrickaya.ru/tehnicheskoe-zadanie-soglasovano-nachalnik-otdela-obrazovaniya-administracii-primorskogo-rajona-stranica-7.html
  • doklad.bystrickaya.ru/uchebno-metodicheskij-kompleks-po-podgotovke-specialista.html
  • college.bystrickaya.ru/1-znachenie-otrasli-v-sisteme-narodnogo-hozyajstva.html
  • learn.bystrickaya.ru/estestvennonauchnaya-kompetentnost.html
  • university.bystrickaya.ru/glava-mo-rabochij-poselok-liman-gricenko-va-poyasnil-chto-preobrazhenie-poselka-eto-zasluga-ne-tolko-administracii-no-i-zhitelej-reshivshih-sozdat-tszh.html
  • lesson.bystrickaya.ru/process-kafka-franc.html
  • pisat.bystrickaya.ru/tehnchne-obslugovuvannya-vagonv-vantazhnogo-parku.html
  • crib.bystrickaya.ru/issledovanie-lingvisticheskoj-prirodi-epiteta-i-ego-informativnoj-znachimosti-v-hudozhestvennoj-literature.html
  • education.bystrickaya.ru/27-chto-takoe-centralnij-processor-lekciya-vvedenie-v-informatiku-chto-takoe-infopmatika-termin-informatika.html
  • paragraph.bystrickaya.ru/konspekt-uroka-s-ispolzovaniem-informacionno-kommunikacionnih-tehnologij-ikt-predmet-himiya-urok-obobsheniya-izuchennogo-materiala-s-issledovaniem-tema.html
  • holiday.bystrickaya.ru/mezhdunarodnie-iniciativi-po-sozdaniyu-mezhdunarodnih-mogilnikov-i-hranilish-radioaktivnih-othodov-v-rossii.html
  • notebook.bystrickaya.ru/ispolzovanie-tablic-dlya-balansirovaniya-vverh-reglament-operativnogo-dispetcherskogo-upravleniya-elektroenergeticheskim.html
  • knigi.bystrickaya.ru/saba-43-pn-biologiya-mektep-ashi-orta-mekteb-kommunaldi-memlekettk-mekemes-kn-11-02-2017.html
  • institut.bystrickaya.ru/tyorkin-kto-zhe-on-takoj.html
  • exchangerate.bystrickaya.ru/gosduma-rf-monitoring-smi-22-aprelya-2008-g.html
  • tasks.bystrickaya.ru/1-onatar-gmesne-debi-taldau-zhasau-tairibin-ideyali-krkemdk-mazmnin-ashu-oushilardi-blmdern-azrg-zaman-lglernen-misal-keltre-otirip-zhjege-keltru.html
  • books.bystrickaya.ru/donald-sazerlend-shutka-akterskogo-masterstva.html
  • studies.bystrickaya.ru/aministrativnaya-otvetstvennost-chast-4.html
  • knowledge.bystrickaya.ru/obrazovaniya-administracii.html
  • universitet.bystrickaya.ru/stiven-king-znaete-oni-klassno-igrayut-stranica-3.html
  • literature.bystrickaya.ru/ekonomika-sssr-georgij-mihajlovich-gerasimov.html
  • education.bystrickaya.ru/29-ideali-anarhicheskogo-obshestva-anarhiya-anarhizm-voprosi-i-otveti.html
  • © bystrickaya.ru
    Мобильный рефератник - для мобильных людей.